Pergunta sobre Yoast SEO do WordPress: LinkedIn mostra imagem errada

Um usuário perguntou ?

Olá

Para o site do meu cliente, tenho um problema com as tags OG.

Neste plugin Yoast, consertei uma imagem do Open Graph. Quando compartilho a URL no Facebook, funciona perfeitamente e o depurador também mostra a imagem correta. (http://personalcoach4u.be/wp-content/uploads/2017/11/facebook-delen.png)

Mas quando compartilho o site no linkedIn, ele não mostra a imagem acima, mas uma imagem de rodapé. Eu sei que o LinkedIn tem um cache há uma semana, então estou esperando há 2 semanas, mas ainda é o mesmo.

Alguma idéia de como posso corrigir isso sem usar uma imagem visível, já que um controle deslizante é usado?

Desde já obrigado, abraços,

Bart

(@mazedulislamkhan)

3 anos atrás

Observamos o seu arranjo Posição e podemos confirmar que o Yoast SEO está gerando com sucesso as metatags gráficas sociais abertas necessárias conforme pretendido.

Então confira a imagem que você definiu og:image e podemos confirmar que atende às necessidades do Linkedin. Portanto, não temos certeza do motivo pelo qual o Linkedin não está exibindo a imagem correta.

Dito isto de acordo com LinkedinSe a imagem atender aos requisitos, mas ainda não estiver visível nas atualizações do LinkedIn, seu site pode estar nos impedindo de arrastar a imagem ou a imagem pode estar em um diretório ou site seguro.

Para obter mais assistência, visite fórum do site do desenvolvedor.

(@jerparx)

2 anos, 12 meses atrás

Fechado por inatividade.

(@mindfire-tnagy)

2 anos, 7 meses atrás

Desculpe por reabrir, mas por medo de se envolver e ajudar outra pessoa, o suporte do LinkedIn me informou que eles priorizam oEmbeds em vez de tags Open Graph. Por padrão (eu acredito), o WordPress adiciona as seguintes linhas ao arquivo <head> alto:

<link rel="alternate" type="application/json+oembed" href=" />
<link rel="alternate" type="text/xml+oembed" href=" />

No JSON/XML resultante, thumbnail_url corresponde à imagem em destaque do meu post. Foi o compartilhamento do LinkedIn em vez das minhas tags Open Graph. Eu desenho essas linhas para:

remove_action('wp_head', 'wp_oembed_add_discovery_links', 10);
remove_action('wp_head', 'wp_oembed_add_host_js');

Tentei compartilhá-lo novamente com uma página diferente no meu site que não tinha sido armazenada em cache por 7 dias (suspiros do LinkedIn) e comecei a desenhar a imagem OG correta.

(@gbougas)

2 anos, 2 meses atrás

Olá Tony .. obrigado em primeiro lugar por reabrir o ticket e dar a solução. Mas me diga uma coisa porque eu tenho o mesmo problema. codifique estas linhas: remove_action (‘wp_head’, ‘wp_oembed_add_discovery_links’, 10); remove_action (‘wp_head’, ‘wp_oembed_add_host_js’);

onde está O que é um arquivo wordpress?

Muito obrigado pelo seu tempo.

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *