WordPress WP Stats Question: A atualização para 12.6.4 causa um erro fatal com a classe “Vectorface Shepherd Shepherd”

Um usuário perguntou ?

Fatal error: Class 'VectorfaceWhipWhip' not found in /kunden/redacted/webseiten/redacted/wp-content/plugins/wp-statistics/includes/classes/class-wp-statistics.php on line 785

A versão anterior do WP Statistics funcionou perfeitamente bem. WP PHP versão 5.1.1 rodando no servidor é um pouco antigo (5.6.34), será por isso?

Este tópico foi alterado 1 ano, 8 meses atrás por.

(@mehrshaddarzi)

1 ano, 8 meses atrás

@veganist

Oi, este pacote foi removido na versão final. Sua atualização parece não estar completa. Faça o download da versão mais recente do arquivo zip do WP-Statistics e faça o upload para o seu servidor.

depois de instalar uma nova versão. vá para a página de configurações de estatísticas do WP (guia IP do visitante) e selecione seu método para obter o IP do usuário.

Esta resposta foi modificada 1 ano, 8 meses atrás por. Esta resposta foi modificada 1 ano, 8 meses atrás por. Esta resposta foi modificada 1 ano, 8 meses atrás por.

(@veganista)

1 ano, 8 meses atrás

Agora desativei o plugin.

(@albertixcom)

1 ano, 8 meses atrás

Olá

mesma pergunta, caí para 12.6.3 (bom trabalho)

(@veganista)

1 ano, 8 meses atrás

Obrigado @mehrshaddarzi! O que eu fiz antes, como o erro era fatal e irrecuperável, foi conectar via FTP e deletar os arquivos do plug-in. Agora instalei o 12.6.4 do zero e ele realmente funciona como esperado novamente. Ainda tinha acesso a registros e preferências anteriores.

Gostaria de saber se há realmente um problema com o procedimento de atualização (clique no plugin de atualização na interface do WP em vez de instalá-lo manualmente) que não remove a biblioteca antiga, portanto, deve ser feito manualmente. Talvez você queira dar uma olhada?

Caso contrário, este problema está resolvido para mim. Obrigado pelo seu trabalho!

Esta resposta foi modificada 1 ano, 8 meses atrás por. Esta resposta foi modificada 1 ano, 8 meses atrás por.

(@albertixcom)

1 ano, 8 meses atrás

Vendido

Meu SERVIDOR WEB é NGINX e PHP7.2-FPM com módulo APC habilitado. O módulo APC executou todas as rotinas de carregamento automático do compositor. Depois de recarregar o serviço PHP-FPM, tudo funciona bem.

Obrigado pelo seu ótimo post.

(@cim)

1 ano, 7 meses atrás

Só percebi agora. Felizmente, os visitantes viram a versão fastcgi em cache do site, então esse não era o caso deles. Eu tive que reiniciar o php-fpm para corrigir isso, provavelmente devido ao armazenamento do código antigo na memória.

Esta resposta foi modificada 1 ano, 7 meses atrás.

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *