Pergunta no WP Google Search do WordPress: a caixa de pesquisa está mostrando/não está funcionando

Um usuário perguntou 👇

Hoje tenho o plugin integrado ao meu site http://www.howto-connect.com/. Mas se o widget WP Google Search (WGS) for adicionado, ele não exibirá nenhuma caixa de pesquisa em uma página da web.

Este tópico foi modificado 3 anos, 6 meses atrás por.

(@gangleri)

3 anos, 5 meses atrás

+1 A caixa costumava funcionar, mas não aparece mais no Chrome (IE e Edge funcionam perfeitamente). Isso provavelmente se aplica ao Google exibindo a tela do iFrame, mas alterar o layout da página de resultados não retorna o widget. Também verifiquei se meu ID de mecanismo de pesquisa mudou, mas não mudou.

(@webshoplogic)

3 anos, 5 meses atrás

Olá,

É um problema específico do site, porque nossos sites de teste exibem o widget da caixa de pesquisa sem problemas.

Posso ver que a caixa de pesquisa agora está sendo exibida no site cutesunita21.

@roy, você poderia nos enviar uma url onde o problema é visto?

obrigado Pedro

(@gangleri)

3 anos, 5 meses atrás

Obrigado Pedro pela sua resposta. Parece uma versão do Chrome. Ontem eu estava trabalhando no site em casa quando notei que o widget de busca não estava visível, então pensei em deletar algo. Quando notei que estava funcionando no IE e no Edge, presumi que era devido ao Chrome. Fiz algumas pesquisas, encontrei tópicos sugerindo que o Google havia alterado a pesquisa personalizada e tentei as opções sugeridas.

Agora estou trabalhando e o widget fazer trabalhar no Chrome. Quando eu quis ver qual versão estava sendo executada aqui, o Chrome começou a atualizar. Quando terminou, o widget não carregou imediatamente, mas depois de um tempo carregou. Portanto, seu plug-in funciona na versão 60.0.3112.101 (Build Officiële) (32 bits) e na minha versão mais antiga aqui (no trabalho). Vou procurar qual versão está acontecendo em casa.

Para informação, seo Este é o site em questão.

(@gangleri)

3 anos, 5 meses atrás

Em casa temos 60.0.3112.90

(@webshoplogic)

3 anos, 5 meses atrás

Obrigado pela informação detalhada.

Minha versão real do Chrome é 60.0.3112.90 e não consigo corrigir isso, a caixa de pesquisa em seu site está sendo exibida corretamente ao usar esta versão do Chrome. Portanto, isso pode não se aplicar à versão do Chrome.

No entanto, o Google possui o Chrome e o Google Custom Search (este plugin apenas adiciona o código do Google a um site WP, mas o Google faz o código de pesquisa), então parece ser um problema do lado do Google.

Sugiro que você relate esse problema ao Google, talvez eles saibam o motivo.

Se pudermos alterar algo no plugin, por favor nos avise.

(@gangleri)

3 anos, 5 meses atrás

Deve ser uma combinação estranha. A linha inferior é que estou atrás de um proxy aqui no trabalho, geralmente causando tais avarias obscuras, mas ironicamente funciona aqui, mas não em casa eu não uso (claro) um proxy. Não é meu link, caso contrário não funcionaria em produtos da Microsoft. É improvável que seja uma combinação de plugins, caso contrário não funcionaria em nenhum lugar. O mesmo vale para as inconsistências do tema.

Eu vou mais fundo. Posso tentar atualizar o Chrome em casa (esperava que fosse feito automaticamente), ver o que vem com o Firefox e continuar a partir daí.

Posso perguntar COMO seu plugin exibe um formulário de pesquisa do Google em um widget? Isso não é iframe, eu acho? A maneira como ele carrega após o resto da página, suponho que este formulário seja carregado diretamente do servidor do Google e não seja exibido usando o WP (e apenas o Google lida com a pesquisa).

(@gangleri)

3 anos, 5 meses atrás

Isso é irritante. O Chrome em casa não mostrou o widget e quando atualizei para a Versie 60.0.3112.101 (Build Officële) (32 bits) a versão mais recente, ainda não há widget.

IE, Edge e Firefox estão bem.

Por que, oh, por que o Chrome não funciona corretamente em casa enquanto funciona?

(@gangleri)

3 anos, 5 meses atrás

Discutir, remover e substituir o widget não é a mesma coisa. O plugin só é desativado e reativado (curiosamente, o widget ainda existe na aparência->widgets quando eu desativo o plugin). Não parece ser um cache do navegador, pois quando mudo o título, ele atualiza imediatamente. Além disso, sempre trabalho com ele em abas privadas…

(@webshoplogic)

3 anos, 5 meses atrás

Você tem alguma mensagem de erro de JavaScript no console do navegador? Você pode ver a caixa de pesquisa em nosso site em seu navegador? (É http://webshoplogic.come a caixa de pesquisa deve ser exibida após clicar no botão de pesquisa no menu).

A caixa de pesquisa não está em um iframe, é um formulário html em algumas tags div geradas pelo Google.

(@gangleri)

3 anos, 5 meses atrás

Nenhuma mensagem de erro, apenas um widget vazio.

O ícone de pesquisa que “produz” a barra de pesquisa é a opção de pesquisa padrão do tema e utiliza a função de pesquisa padrão do WP, portanto: apenas site atual. Eu uso seu plugin para explorar a possibilidade de pesquisar todo o site.

O que acontece no Chrome no meu computador é que aparece o título do widget (“site de pesquisa”), mas não há uma pesquisa personalizada no Google. É apenas um widget vazio com apenas um título. O resto da barra lateral até se move para cima para preencher o espaço, então não parece haver um espaço preto onde uma pesquisa no Google é necessária. Outros disseram o contrário: o site permanece o mesmo antes que a barra de pesquisa do Google seja carregada. Em outro navegador, você também pode ver que a barra de pesquisa carrega um pouco mais tarde do que o restante da página.

Claro que não estou em casa no momento (início do dia de trabalho), então não posso tentar ver se vejo a barra de pesquisa em seu site. Embora seja uma boa sugestão. Espero pensar em um cheque quando chegar em casa.

(@gangleri)

3 anos, 5 meses atrás

Desculpe, demorei um pouco para lembrar de tentar isso e acessar meu PC ao mesmo tempo :-/

Resultado: quando você clica no ícone de pesquisa em seu site, uma barra aparece, mas permanece vazia. Não tenho espaço para clicar para digitar um termo de pesquisa.

Basta verificar se o código-fonte do meu site é o mesmo no Chrome e no IE. Acho que isso significa que o Chrome não bloqueia nada, mas também não mostra tudo.

(@gangleri)

3 anos, 5 meses atrás

Percebi que pesquisar no WP.org também não funciona. Posso digitar um termo de pesquisa aqui, mas nada acontece. Deve ser a instalação do Chrome. Vou reinstalar e ver o que acontece.

(@gangleri)

3 anos, 5 meses atrás

Suspiro, essa deve ser a opção um… Reinstalação resolvida.

Com licença e obrigado pelo seu tempo.

(@webshoplogic)

3 anos, 5 meses atrás

Ficamos felizes que o problema tenha sido resolvido, obrigado pelo feedback.

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *