Pergunta no WordPress Social Slider Widget: Este plugin é péssimo, altera o tempo máximo de execução do valor php

Um usuário perguntou ?

Este plugin é péssimo, por que o valor da variável php “max_execution_time” muda?

Onde você aprendeu um programa?

Afeta o funcionamento do resto dos plugins, as configurações de hospedagem e a pressão geral da palavra.

esse plugin deveria ser banido

if (!ini_get(‘max_execution_time’) ||ini_get(‘max_execution_time’)

ini_set(‘max_execution_time’, 300);

$disabled = disable(‘,’,ini_get(‘disable_functions’)); if (!in_array(‘set_time_limit’, $off)) { set_time_limit(300); }}

(@jetonr)

3 anos, 3 meses atrás

Você tem seu próprio plugin que gostaria de promover? O plugin é gratuito e obviamente não puxa. max_execution_time não é crime.

integer max_execution_time Isso define o tempo máximo em segundos que seu script pode executar antes que o analisador o encerre. Isso ajuda a evitar que scripts mal escritos se conectem ao servidor. A configuração padrão é 30. Ao executar o PHP a partir da linha de comando, a configuração padrão é 0.

Chamadas do sistema, operações de streaming, etc. não o fazem. Afeta o tempo máximo de execução. Veja a função set_time_limit() para mais detalhes.

Você não pode alterar essa configuração com ini_set() enquanto estiver executando no modo de segurança. A única maneira de trabalhar é desabilitar o modo de segurança ou alterar o tempo limite no php.ini.

Seu servidor web pode ter outras configurações de tempo que também podem interferir na execução do PHP. O Apache tem uma diretiva Timeout e o IIS tem uma função de tempo limite CGI. Ambas as predefinições para 300 segundos. Verifique a documentação do seu servidor web para obter detalhes específicos.

(@fabrisancho)

3 anos, 3 meses atrás

Alterar o valor da configuração do php é crime, pois esse valor não deve ser associado a um plugin. Não só compromete a segurança da página, mas também afeta outros plugins, essa mudança de valor é sempre executada, no admin, na web, no modo cli, decência nem mesmo colocada no gancho opcional.

esse plugin é uma porcaria e o pior é que vocês são programadores ruins, aceitam o erro quando eles te falam e decidem que seria normal,

você não só não resolve, você também justifica

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *