Pergunta sobre o WordPress Broken Link Checker: curl_exec() foi desabilitado por motivos de segurança

Um usuário perguntou ?

Olá! Em primeiro lugar, obrigado por este ótimo plugin (e é grátis!). Eu tenho usado este plugin há mais de um ano e ele me ajudou a corrigir links quebrados no meu site WordPress. Tudo parece estar funcionando bem até que vi muitos links quebrados no site WP e todos eles tinham “Erro desconhecido”.

Então o que eu fiz foi: – Verifique alguns dos links quebrados e todos eles funcionam bem. Eu posso vê-los na web muito bem;

– Verifiquei os logs de erros (já que tenho um VPS dedicado que eu mesmo gerencio) e encontrei este erro “curl_exec() está desabilitado por motivos de segurança em /path/to/wp-site/example.com/wp-content/plugins / verificador de links quebrados / módulos / verificadores / http.php online 262 ienes;

– verifique php.ini para verificar se eu tenho curl_exec() desabilitado (mas não me lembro de ter feito isso) e infelizmente não fiz;

– Tentei reinstalar o curl “apt install php7.0-curl” mas o sistema diz que o curl já está em sua versão mais recente.

Verifiquei a última atualização do seu plug-in e foi em 7 de fevereiro de 2018. Acho que isso é um problema com o plug-in, pois não me lembro de editar nenhuma configuração e esse plug-in precisa de uma atualização e corrige esse problema.

Espero que você resolva esse problema o mais rápido possível.

(@kouteki)

1 ano, 11 meses atrás

Plugin atualizado para suportar PHP7.2 e WP 5.1.1. Estes dois têm sido a causa de muitos dos erros recentes.

Deixe-me saber se o problema persistir com a versão mais recente do BLC.

Cumprimentos, Nemanja

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *