Pergunta de suporte do WordPress SVG: SVG não visível no Chrome e Firefox: Aviso de segurança

Um usuário perguntou ?

Olá

As imagens SVG no meu site não aparecem no Chrome e Firefox (no Mac) e estou recebendo um aviso de segurança de que as imagens não são seguras. Todos os svgs têm URL https.

Isso é um problema com as próprias imagens ou preciso instalar e desinstalar o plugin?

Quando o plugin foi adicionado pela primeira vez, foi quando o site era apenas http.

(@benbodhi)

3 anos, 6 meses atrás

Olá,

Obrigado por seu apoio e por usar meu plugin!

Este parece ser um problema com a forma como você alterou seu site para https. Ouso dizer que você está recebendo avisos de conteúdo misto. Certifique-se de ter mudado totalmente para https corretamente.

Aqui está um bom guia específico para WordPress:

E aqui está um ainda mais profundo:

Deixe-me saber como você vai.

(@chanell82)

3 anos, 6 meses atrás

Obrigado pela resposta e pelos links.

Portanto, os URLs http: restantes são removidos, o bloqueio é bloqueado e não há mais alertas de segurança. Mas os svgs ainda não estão aparecendo no firefox e chrome.

Quando coloco a altura e largura em pixels, as páginas não carregam. Muito confuso.

(@benbodhi)

3 anos, 6 meses atrás

Isso é raro. Por favor me mande um link para eu dar uma olhada.

(@chanell82)

3 anos, 6 meses atrás

é

(@benbodhi)

3 anos, 6 meses atrás

Não vejo nenhum SVG em sua marca. Onde você colocou o arquivo SVG?

Preciso do máximo de detalhes possível para ajudá-lo a resolver o problema.

(@benbodhi)

3 anos, 6 meses atrás

Encontrei um na sua página sobre isso. Parece que você só precisa especificar o que deseja, ele é exibido em zero pixels. Eu adicionei uma largura para que você possa ver:

(@chanell82)

3 anos, 6 meses atrás

Acima e abaixo.

Você pode abrir o link no Safari? Ou no celular? Então eles aparecem nos lugares certos.

(@benbodhi)

3 anos, 6 meses atrás

parece que você conseguiu definir um tamanho agora 🙂

Me avise se você ainda tiver problemas.

(@chanell82)

3 anos, 6 meses atrás

Eu fiz!! Também notei que não estava funcionando antes porque só adicionei os tamanhos aos seletores de classe (sem pular a img).

Muito obrigado pela ajuda e paciência.

(@benbodhi)

3 anos, 6 meses atrás

Boas notícias! Fico feliz que tenha resolvido ?

É um prazer, fico feliz que tenha gostado do meu plugin!

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *