Pergunta sobre o Wordfence Security do WordPress: erro cURL 35: erro de protocolo SSL desconhecido

Um usuário perguntou ?

O Wordfence está instalado no meu site e estava perfeitamente bem, mas há alguns dias é impossível realizar uma nova verificação: recebo este erro:

“A chamada da API do Wordfence falhou ao resolver os endereços IP: Falha ao conectar-se aos servidores de verificação do Wordfence: erro cURL 35: erro de protocolo SSL desconhecido para noc1.wordfence.com:443”

E a varredura não inicia…

Alguma ideia? Tentei reinstalar todos os arquivos do wordfence, mas não funciona

(@jason-kickmouth)

2 anos, 10 meses atrás

@alizesonline Eu ouço você Gilles ? Mas curiosamente, a OVH está investigando meu ticket de suporte que destacou um bug na minha versão php… claro que isso não é um problema do Wordfence. Posso perguntar quais versões de php e cURL você relatou quando executou o diagnóstico do WF? Eu tinha php 5.4.45 e cURL 7.21.0 até onde eu sabia do meu painel de controle e configurações da OVH que eram 7.2 e 7.38.0, então claramente algo está errado. Também aprecio o Wordfence, prefiro-o a qualquer outro plugin de segurança.

(@alizesonline)

2 anos, 10 meses atrás

@jason-kickmouth

Leia minha resposta editada acima. Corrigido o problema com a alteração do ambiente PHP do host de “legado” para “estável”.

Para tal, pode utilizar o painel OVH e editar a configuração do PHP, ou editar o ficheiro “.ovhconfig” na raiz do servidor: insira “container.image = stable” replace “container.image = legacy”

Isso funciona com PHP 5.6 e PHP 7.0

Eu espero que isso ajude.

lançador de tópicos

(@chloebgt)

2 anos, 10 meses atrás

obrigado @alizesonline pela sua resposta! Também funciona perfeitamente no meu site. O suporte da OVH me disse exatamente a mesma coisa: mude minha configuração do PHP de “legado” para “estável”. Legacy usou a antiga versão Open SSL de 0.9.8o, e Stable usa 1.2 do protocolo TLS.

Estou fechando o tópico.

(@wmconlon)

2 anos, 10 meses atrás

Meu Centos 5.11 não possui nenhum pacote de atualização para OpenSSL ou libcurl, então precisarei criar meu próprio trabalho.

Alguém sabe sobre scripts que irão rdiff meu wordpress contra wordpress goldfiles?

(@eurostar)

2 anos, 8 meses atrás

Obrigado @alizesonline, funcionou perfeitamente!

(@rubenblan)

2 anos, 7 meses atrás

Olá:

Alguma notícia sobre este assunto? Eu só tenho o Wordfence instalado e não consigo digitalizar. Eu recebo este erro:

wp_remote_post() test to noc1.wordfence.com failed! Response was: cURL error 35: SSL connect error

CURL e ssl são atualizados:

# curl --version
curl 7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.27.1 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
Protocols: tftp ftp telnet dict ldap ldaps http file https ftps scp sftp 
Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz 

# openssl version
OpenSSL 1.0.1e-fips 11 Feb 2013

Obrigado!

(@gip94)

2 anos, 5 meses atrás

Olá, o meu site está alojado na OVH, como utilizador ‘chloebgt’. Mudei a opção PHP de ‘legado’ para ‘estável’ e mudei para PHP 5.6.

Quando me conecto ao meu servidor com SSH, vejo que recebo as versões corretas de openssl (OpenSSL 1.0.1t) e curl (curl 7.38.0).

Mas o WordFence diz que a versão openssl é ruim (0.9). No entanto, ele diz que o PHP é 5.5.38 e o curl é 7.21.0 …

Wordfence Labs, você poderia me ajudar a resolver este problema? Não consigo escanear meu site WordPress. Muito obrigado antecipadamente

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *