Pergunta sobre como corrigir o WordPress do WordPress: Onde você pode obter o PHP 5.6.20 para Windows?

Um usuário perguntou ?

Meu site WP foi hackeado recentemente, então quero atualizá-lo. Ele é executado no Windows Server 2008. A página de atualização do WP informa que “o WordPress 5.4.1 requer PHP versão 5.6.20 ou superior. Você está executando a versão 5.4.24”. O único problema de PHP que posso ter para o Windows é a v7. *. Tenho a v7.4.6 instalada, mas meu site WP retorna um erro com essa versão. Alguém pode me direcionar para um site de download que tenha versões mais antigas do PHP para Windows, especificamente v5.6.20?

Este tópico foi modificado 7 meses, 2 semanas atrás por.

(@ alegremente)

7 meses, 2 semanas atrás

Veja onde você verá que o PHP 5.6 (que é a versão mínima que você pode usar) tem um ano e meio de EOL, então você não recebe nenhuma atualização de segurança. Não é uma boa ideia voltar assim. Você pode usar 7.2 ou 7.3, ou o mais recente que já testou, mas cada um de seus plugins/temas exigirá algumas atualizações. Aconselho você a esperar pelo seu 7.4 e corrigir seus erros.

(@diondesigns)

7 meses, 2 semanas atrás

Você pode encontrar versões mais antigas do PHP para Windows aqui:

Não é uma boa ideia usar uma versão do PHP anterior à 7.2.0 com o WordPress 5.3 ou posterior. Versões recentes do WordPress incluem código (implementação PHP da libsodium) que roda brutalmente lento com versões mais antigas do PHP.

(@ibertrix)

7 meses, 2 semanas atrás

Eu empresto que você deve usar pelo menos 7.2. Se nenhum plugin ou tema funcionar com 7.2, tente 7.1 ou 7.0, que também é o fim da vida útil, mas mais atualizado.

(@ianmanning)

7 meses, 2 semanas atrás

OK, vou tentar 7.2 – obrigado por toda a ajuda

Isto foi útil?

0 / 0

Deixe uma resposta 0

O seu endereço de email não será publicado. Campos obrigatórios são marcados *